周线macd金叉选股公式

我来帮TA回答

求通达信选股公式 :周线的MACD在0轴以上以上第一次金叉,最近的时间

直接设置条件选股就行,无需公式.

能不能编写一个MACD周线和月线同时在零轴上金叉的选股公式?

月DIF:="MACD.DIF#MONTH"(12,26,9);
月DEA:="MACD.DEA#MONTH"(12,26,9);
月MACD:=(月DIF-月DEA)*2;
周DIF:="MACD.DIF#WEEK"(12,26,9);
周DEA:="MACD.DEA#WEEK"(12,26,9);
周MACD:=(月DIF-月DEA)*2;
AA:=CROSS(月DIF,月DEA) AND 月DEA>0;
BB:=CROSS(周DIF,周DEA) AND 周DEA>0;
COUNT(AA OR BB,3)=2;
说明指标没任何问题,你的条件太严格啦,估计没票,你放其他时间段选验证

求周线三线金叉的公式

可以编写这三个金叉同时发生的选股公式。

编写一个通达信选股公式,MACD周线金叉

选股公式如下,选股周期选择周线,

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

XG:BARSLAST(CROSS(DIF,DEA))>0 AND DIF>DEA;

能不能编写一个MACD周线和月线同时在零轴上金叉的选股公式?

月DIF:="MACD.DIF#MONTH"(12,26,9);
月DEA:="MACD.DEA#MONTH"(12,26,9);
月MACD:=(月DIF-月DEA)*2;
周DIF:="MACD.DIF#WEEK"(12,26,9);
周DEA:="MACD.DEA#WEEK"(12,26,9);
周MACD:=(月DIF-月DEA)*2;
AA:=CROSS(月DIF,月DEA) AND 月DEA>0;
BB:=CROSS(周DIF,周DEA) AND 周DEA>0;
COUNT(AA OR BB,3)=2;
说明指标没任何问题,你的条件太严格啦,估计没票,你放其他时间段选验证

请高手提供一个周线MACD和日线MACD同时交金叉的条件选股公式

XG:CROSS(MACD.DIF,MACD.DEA) AND CROSS(MACD.DIF#WEEK,MACD.DEA#WEEK);

(信号非常少)